Help on Deploying Mifos on Localhost

Dear all,

I hope this email finds you well and safe. I am requesting for help on how I can deploy mifos locally on my machine operation on Linux Mint with an installed xampp server running on my machine. I have tried several options but get stuck along the way.

I am also new in dev work. The latest i tried was procedure available here https://github.com/openMF/community-app. I didn’t go beyond installing npm . The error was:

justus@justus:~$ sudo apt-get install npm nodejs-legacy
[sudo] password for justus:
Reading package lists… Done
Building dependency tree
Reading state information… Done
Package nodejs-legacy is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
nodejs:i386 nodejs

E: Package ‘nodejs-legacy’ has no installation candidate

Kindly your support will be highly appreciated.

Thank you,

Hello Just us and welcome to the forum. It’s been a few days since your post so I don’t know if this has been solved. I also came across the same error you outlined above. I was able to get over it by running the following

curl -sL https://deb.nodesource.com/setup_8.x | sudo -E bash -
sudo apt-get install -y nodejs nodejs-legacy

Let me know if this helps